Opensuse 12.2 Video Problem

Alright, im not necessarily new to linux, ive been using it for several years, though never as a primary OS-usually to rescue windows systems. Now, Ive decided to go to linux as my primary OS, and im using OpenSuSe 12.2 (ive always enjoyed it) Here is my issue, Ive gotten it installed fine, all drivers up to date. Im running Mozilla firefox, with java and the icedtea plugins so as to watch videos such as youtube. here is the issue, when watching a video, such as from youtube, sometimes it will play fine-video and sound, but other times, I will only get the sound, and not any video. Usually, say if its a music video, if its the artists primary video it works-if its a remake, it wont. Most news videos will not, but nearly all videos embedded in another site work perfectly. Im thinking its some kind of bug in a plug in, but was wondering if anyone here had experienced a similar issue before and knew how to fix it-because Ive never ran into it before, in previous versions of OpenSuSe (and other linux variants ive used) videos have always 100% worked, or 100% not worked, and I could usually track it down to a bug or driver inconsistency, I havent been able to do so this time. Thanks for your help in advance.

Again, Im running OpenSuSe 12.2 with mozilla firefox-which is up to date. Im running it on a custom built computer with an AMD 945 quad core CPU, ASUS M4A89GTD motherboard, and 2 ATI 4890s in crossfire. So far, everything else is running smoothly, without any hiccups.
well, after doing a little work, Chromium (which I hate) plays everything just fine without any issues-and a little research shows firefox has been having flash problems recently (lot of people complaining about it) So, just need to find a way to fix the flash as Im pretty sure it has to do with a flash/firefox inconsistency somewhere.
I run ubuntu 12.04 and recently I also had issues ith the flash plugin but since the last updte all is fine.
I don't run open suse, but a lot of the video problems I have had have been cured by either installing updated video codecs or just reloading them. The fact that you have trouble with a remake, from one site but not from another, suggests a codec issue. ie different codecs used on different sites.
no from the same site, im talking about the official video-verses a remake, but all on youtube. But Ill try reloading my codecs, and see if that will do it, its a good idea-though the fact it works with chromium makes me suspect that isnt the issue.
no from the same site, im talking about the official video-verses a remake, but all on youtube. But Ill try reloading my codecs, and see if that will do it, its a good idea-though the fact it works with chromium makes me suspect that isnt the issue.
I went back and reread your post to insure proper reading and what I see is that you are experiencing a codec issue. I believe I will be in agreement with Calvin and suggest you reload them from what ever source Open Suse uses for native. The update I was speaking of was the regular Native Ubuntu update that ocures two or three times daily and sometimes just once a day. I've ceased going to the origin because, often, bugs are not worked out for every OS until the writers of that system have worked it over.

The point raised by Calvin about the different sources applies here. This issue is not experienced so much with Windows because MS has complete control over their software and that's the only plus to their policies. All GNU software is much more flexible. Issues like this are best addressed at the forums established by both the writers and owners of the software. i.e. With Ubuntu we have the Ubuntu Forums and with Simply Mepis there are the Mepis Lover's forums. In addition to these the Linux Forums at are sensational at solving issues when you post in the, in your case, Open Suse Division forum.

Praying for the solution.
tried at a tech site im active on with a strong linux support group. theyre coming up with pretty much the same suggestions, and not really working-and the codecs didnt change anything. I often ask for help from 2 different locations when I have an issue, one thats profession is what Im after-and one outside, because those that do it all the time have a lot of good info, but sometimes have a tendency to think inside the box to much.
One thing that occur to me, that might impact on fire fox but not chromium is :
the remakes could be formatted differently from the original. Sort of mp3 redone as mp-4 h.264 try
sudo apt-get update
sudo apt-get install x264
see if that helps
no, not yet. I tried your method didn't work, I have one more thing to try another friend of mine suggested that i haven't had time to try yet, will let you know how it goes after Im done.
hmmmm well, let me rephrase, I guess I did somehow manage to fix it, did the sudo thing, got some kind of error code (cant remember what it was late and I was tired) so I figured it didnt work, or did something wrong since I was so tired so I shut it down, gave up on it, and just now tried it, I guess that did fix it. All the videos are working fine now. Thankyou for your assistance.

But just as an example of what it was doing, it would play the music for this vid but not the video

but it would play this just fine
glad things are going OK now.
I played the first vid clip and had to scrape the speakers off the rear wall.:)
there seems to be bug in most linux distros. after an application install, either it does not report the operation is finished or else it will post an error message. But only after the job is done as you have just observed.
lol sorry about that, I shoulda warned you I enjoy the harder music. I was mainly doing those because I knew that that video was one that I was having issues.