Welcome to Christian Forum Site
Find answers, ask questions, and connect with our community of christians from around the world.
Register now

Update status (evening of Jan 21)

Feb 10, 2015
769
935
93
Maryland
So, just to check...
This site is still having internet issues, Correct?

None of my windows browsers (chrome, edge, firefox) are getting past the home page, even after cleaning cookies & data and ensuring i have the latest releases.

My android tablet is a mixed bag. Chrome is still not working, but I can get by on the Dolphin browser, which is probably too unsophisticated to respond to security issues.
 

Fish Catcher Jim

Inactive
Feb 7, 2015
10,803
13,213
113
So, just to check...
This site is still having internet issues, Correct?

None of my windows browsers (chrome, edge, firefox) are getting past the home page, even after cleaning cookies & data and ensuring i have the latest releases.

My android tablet is a mixed bag. Chrome is still not working, but I can get by on the Dolphin browser, which is probably too unsophisticated to respond to security issues.
Replace http:// WITH https://

I did but my bookmark kept reverting back to the old http:// also using chrome. Deleted the bookmark logged back in and saved it all over and all is well.
Blessings
 
  • Like
Reactions: Siloam
Feb 10, 2015
769
935
93
Maryland
Replace http:// WITH https://

I did but my bookmark kept reverting back to the old http:// also using chrome. Deleted the bookmark logged back in and saved it all over and all is well.
Blessings
I seem to notice the same behavior as FCJ. I update a bookmark to HTTPS and it goes to the site, but things go wrong when I click another link. Probably the browser being too smart for our own good.

Best advice is to delete and re-add bookmark as brother Jim describes
 
  • Like
Reactions: Fish Catcher Jim